Ativando a conta Administrador no Windows 7

Algumas pessoas estão familiarizadas com versões anteriores do Windows, e estão curiosas para saber o que aconteceu com a conta “Administrador”, criada por padrão. Esta conta ainda existe, mas como habilita-la?

A conta é criada no Windows 7 e no Windows Vista, mas até que você habilite, não poderá usa-la. Se você está tendo problemas com alguma coisa, e precisa executar como Administrador, você pode habilita-la com um simples comando.

Nota: Você não vai querer usar a conta Administrador para outra coisa a não ser para resolver problemas. De fato, você não deverá usa-la para tudo.

Habilitando a conta Administrador

Primeiro você precisa abrir o prompt de comando com privilégios de administrador, clicando com o botão direito no prompt de comando e selecionado “executar como administrador”.

Agora digite o seguinte comando:

net user administrator /active:yes

Você deverá ver uma mensagem, dizendo que o comando foi criado com sucesso.  Quando você fizer logoff, deverá ver a conta Administrador disponível.

Note que nenhuma senha é definida por padrão, então se você quiser habilitar a conta, deverá definir uma senha.

Desabilitando a conta Administrador

Tenha certeza que você está logado com uma conta de usuário comum, então abra o prompt de comando novamente, e digite o seguinte comando:

net user administrator /active:no

A conta Administrador estará desabilitada, e você não verá mais na tela de login.

AGENDA

Reler Introdução ás WANs

[routemyworld.com, http://www.youtube.com/user/OOteum, http://testinside.blogspot.com/Perguntas basicas, Respostas basicas

segunda – vlan e vtp

terça – rotas estaticas, vlsm e sumarização, acl

quarta – ospf e eigrp

quinta – frame-relay

sexta – ipv6 e nat

Reler o livro da cisco, somente os “topicos chaves” e adicionar as observações nos resumos

ler o livro CCNA Portable Command Guide

reler todos os resumos.

Protocolo OSPF

Para fins didáticos, o OSPF pode ser dividido em três passos:

  1. Formação de adjacências.
  2. Troca de banco de dados
  3. Escolha de melhor rota para cada sub-rede

1 – Para formas adjacencias, os roteadores vizinhos tem os seguintes requisítos:

– Estar na mesma sub-rede

– Mesmo intervalo hello e dead

Mesmo ID de área

1.1 Inicialmente, os roteadores estão no estado down de relação de vizinhança. Assim que eles são conectados no mesmo link, eles passam a trocar pacotes hello. Neste momento, eles estão no estado init. Quando em roteador recebe um pacote hello, ele o envia de volta no mesmo link, e assim que ele receber outro pacote hello listando seu próprio endereço (router id), ele define seu estado com o vizinho de two-way.

2 – Roteadores vizinhos trocam seus LSDB (link-state database) quando estão em um mesmo link point-to-point. Quando estão em uma rede broadcast, eles não trocam seus LSDB diretamente. em vez disso, eles designam um Designated Router (roteador designado) e um Backup Designated Router (roteador designado de backup). Todos os roteadores em cada área trocam seus LSDBs com o DR, se o DR não estiver disponível, eles fazem com o BDR.

3 – Após terem trocado suas LSBDs com seus vizinhos, os roteadores rodam o algoritmo SPF para determinar a melhor rota até cada sub-rede.

Configurando o RID do OSPF

  • Se o subcomando de interface OSPF router-id rid estiver configurado, este é o valor utilizado como RID
  • Se qualquer interface loopback tiver um endereço configurado, o endereço ip mais alto entre as interfaces loopback sera usado
  • O roteador escolha o mais alto endereço ip a partir de todas as interfaces operantes (up/up)


Protocolo STP (Spanning-Tree)

O Protocolo STP pode ser dividio em três etapas:

1 – Escolha de um switch-raiz (root brigde)

2 – Escolha de uma porta-raiz em cada switch não-root

3 – Escolha da porta designada em casa segmento LAN.

A escolha do switch-raiz é feita com base no valor de BID (Brigde-ID) de cada swich, sendo o switch com o menor BID eleito o switch-raiz.

O Valor do BID é formado pelo valor da prioridade (default 32768) mais o endereço MAC Address, exemplo: 32768:0200.0003.0202

A escolha da porta-raiz de cada switch-não-root é feita verificando o custo. O custo é baseado na largura de banda de cada interface, no caso de uma interface Fast Ethernet, o custo é 19. O switch soma o custo de todas interfaces de saída, em todos os switchs, até o switch-raiz, e verifica qual tem o menor custo. Um jeito melhor de verificar o custo até o switch-raiz, é verificar cada caminho que um frame poderia percorrer até o switch-raiz, e somar esses custos, somando o custo de cada interface de saída, em cada switch (a interface de entrada de cada switch não é contada nessa soma).

Os três maiores problemas de camada 2 sem o protocolo STP são:

Tempestade de broadcast (broadcast storm)

Instabilidade da Tabela Mac

Recebimento de multiplos frames idênticos

Os valores de timers padrão do STP são:

Hello Timer: Período de tempo entre “hellos” criados pela raiz. – 2 Segundos

Max Age: Tempo que o switch deve aguardar até tentar alterar a topologia – 10* hello timer

Forward Delay: Tempo em que o switch fica entre o modo “listening” e “forward”

Etherchannel é um recurso do STP no qual um switch pode determinar mais de 2 interfaces para ser considerada um unico “link”. Um exemplor seria 2 interfaces Fast Ethernet de um mesmo switch, conectadas diretamente a outras 2 interfaces de outro switch, nesse caso, teríamos um canal virtual de 200mbps. Para configurar o etherchannel em uma determinada interface, basta entrar com o seguinte subcomando de interface:

Router(config-if)#channel-group 1 mode on

Neste caso, o “1” ter que ser o mesmo nos dois switchs, e nas 4 interfaces.

O STP também tem o recurso BPDUGuard, que faz com que determinada porta do swich não processe BPDUs, afim de nao definir um switch-raiz naquele segmento. Isso evita que um hacker conecte um switch com prioridade menor afim de tornar esse switch o switch-raiz da rede. Para ativa-lo, digite:

Router(config-if)#spanning-tree bpduguard enable

Para alterar o BID de um switch, na intenção de torná-lo o switch-raiz, entre com o seguinte comando:

Router(config)#spanning-tree vlan 1 root primary

Para ativar o RSTP, utiliza o comando de configuração global spanning-tree mode rapid-pvst

Em RSTP, links do tipo Egde conectam estações de trabalhos e servidores, enquanto links do tipo PTP (point-to-point) fazem conexões entre switches.

Protocolo NAT

NAT (Network Address Translation)

Devido a popularização da internet na década de 90, tornou-se óbvio que os endereços ipv4 iriam rapidamente se esgotar. Alguns recursos foram criados para retardar essa escassez, e o NAT foi um deles.

O NAT se consiste basicamente em converter endereços ip privados (endereços ip inválidos, como 192.168.1.1, 10.0.0.1, 172.16.10.1…) em endereços ip públicos, roteáveis na internet.

Para o NAT funcionar a contento, todos os roteadores públicos descartam endereços ip privados, assim, em uma rede interna, com a ajuda do NAT, esses endereços podem ser traduzidos para endereços públicos, podendo se comunicar com a internet.

Os três principais tipos de NAT no IOS são: Estático, Dinâmico e PAT. A seguir a sintaxe de configuração de cada um deles.

NAT Estático

  • Definir a interface na qual os pacotes serão traduzidos (inside local)
  • Definir a interface na qual os pacotes serão enviado a rede pública (inside global)
  • Definir o mapeamento estático endereço privado – endereço público

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip nat inside

Router(config)#interface serial 0/3/0

Router(config-if)#ip nat outside

Router(config)#ip nat inside source static 192.168.1.1 200.0.0.1

Router(config)#ip nat inside source static 192.168.1.2 200.0.0.2

Router(config)#ip nat inside source static 192.168.1.5 200.0.0.5

Router#show ip nat translations

Pro  Inside global     Inside local       Outside local      Outside global

—  200.0.0.1         192.168.1.1        —                —

—  200.0.0.2         192.168.1.2        —                —

—  200.0.0.5         192.168.1.5        —                —

NAT Dinâmico

  • Definir a interface na qual os pacotes serão traduzidos (inside local)
  • Definir a interface na qual os pacotes serão enviados a rede pública (inside global)
  • Definir uma ACL com os endereços ips privados
  • Definir um pool com o intervalo de endereços ips públicos

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Router(config)#ip nat pool pool-public 200.0.0.1 200.0.0.200 netmask 255.255.255.0

Router(config)#ip nat inside source list 1 pool pool-public

Router#show ip nat translations

Pro  Inside global     Inside local       Outside local      Outside global

—  200.0.0.1         192.168.1.1        —                —

—  200.0.0.2         192.168.1.2        —                —

—  200.0.0.5         192.168.1.5        —                —

icmp 200.0.0.3:3       192.168.1.6:3      192.168.2.2:3      192.168.2.2:3

Obs.: Repare que o pool de endereços ips públicos pode ser menor que o intervalo de endereços privados.

PAT

  • Definir a interface na qual os pacotes serão traduzidos (inside local)
  • Definir a interface na qual os pacotes serão enviados a rede pública (inside global)
  • Definir uma ACL com os endereços ips privados
  • Configure comando ip nat inside source list [acl-number] [interface] [interface-name] [overload]

Router(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Router(config)#ip nat inside source 1 interface serial 0/3/0 overload

Router#sh ip nat translations

Pro       Inside global              Inside local         Outside local          Outside global

icmp    200.0.0.251:1025       192.168.1.2:3     192.168.2.1:3         192.168.2.1:1025

icmp    200.0.0.251:1024       192.168.1.5:3     192.168.2.2:3         192.168.2.2:1024

icmp    200.0.0.251:3             192.168.1.6:3     192.168.2.100:3     192.168.2.100:3

icmp    200.0.0.251:4             192.168.1.6:4     192.168.2.100:4     192.168.2.100:4

IPV6

Resumo Endereço Ipv6

Os endereços Ipv6 são grafados com 128 bits, divididos em 8 quartetos, em formato hexadecimal, da seguinte forma:

FE00:0000:0000:0001:0000:0000:0000:0056

Para facilitar, ele pode ser abreviado de acordo com as seguintes regras:

  • Omita os 0s na frente em qualquer quarteto.
  • Represente um ou mais quartetos, todos com 0s hexa, com dois pontos duplos (::), mas somente uma vez em cada endereço.

Deste modo, o exemplo acima pode ser abreviado da seguinte forma:

FE00::0:1:0:0:0:56

ou ainda:

FE00:0:0:1::56

O uso de prefixos nos endereços ipv6 é exemplificado a seguir.

2340::/12 – é atribuído para um ISP, que corresponde ao binário:

0010 0011 0100 0000 0000 0000 0000 0000 … ::

Ou seja, o bloco de 12 digitos binários (em negrito) é fixo, e os 0s podem variar.

Na Seqüência, o ISP prove um bloco de endereços /32 para uma companhia cliente:

2340:1111::/32 – em binário:

0010 0011 0100 0000 0001 0001 0001 0001 0000 0000 … ::

Ou seja, o bloco de 32 dígitos binários (em negrito) é fixo, e os 0s podem variar.

Logo a seguir, a companhia pode usar o seguinte bloco:

2430:1111:AAAA/48 – em binário:

0010 0011 0100 0000 0001 0001 0001 0001 1010 1010 1010 1010 … ::

Ou seja, o bloco de 48 dígitos binários (em negrito) é fixo, e os 0s podem variar.

Unicast: endereço ip atribuído a interfaces individuais.

Multicast: Um endereço que representa um grupo dinâmico de hosts.

Anycast: Uma função na qual diversos servidores podem usar o mesmo endereço anycast, com pacotes enviados pelos clientes sendo encaminhados para o servidor mais próximo, permitindo a distribuição do trafego entre diferentes servidores.

Unicast Global: Endereço semelhante aos ips públicos no ipv4, e geralmente começam com 2000::/3 ou 3000::/3

Unicast Local: Endereço semelhante aos ips privados no ipv4, e geralmente começam com FD (FD00::/8). A seguir, o formato de uma endereço unicast local:

Prefixo da Sub-rede
8 bits 40 bits 16 bits 64 bits
FD ID GLOBAL SUB-REDE ID DA INTERFACE

Unicast Link-local: Endereço usado quando se envia pacotes para a sub-rede local; os roteadores nunca encaminham pacotes destinados a link-local para outras sub-redes. Um endereço link-local é auto-designado pelo host antes mesmo de estar em uma sub-rede, por exemplo, quando um host envia um pacote RS (router solicitation) ele envia com o endereço de origem seu link-local.

Endereços link-local começam sempre por FE80, FE90, FEA0 e FEB0, ou seja, FE80::/10.

Um exemplo de endereço link-local, iniciado com FE80, mais 54 0s binários, mais o ID de interface do host no formato EUI-64

10 bits 54 bits 64 bits
FE80/10 Todos 0s ID da interface
1111111010 ::

Multicast Link-local: Endereços multicast link-local começam com FF02::/16, um exemplo a seguir, dos endereços ipv6 multicast link-local usados por protocolos de roteamento:

Endereço de loopback: ::1 = 127.0.0.1

Rotina de inicialização de uma rede ipv6:

1 – O host calcula seu endereço link-local

2 – O host envia uma mensagem RS (router solicitation) do NDP, para o endereço multicast FF02::2 para todos os roteadores, solicitando informações sobre roteadores default e prefixos.

3 – Os roteadores respondem com uma mensagem RA para o endereço de multicast FF02::1, para todos os hosts, informando sobre o roteador default e prefixos.

Se a atribuição dinâmica for autoconfiguração stateless, ocorre o seguinte:

1 – O Host constrói seu endereço ip baseado nas informações recebidas pela RA e calcula um ID de interface EUI-64 baseado em seu endereço MAC.

2 – O Host usa o DHCP para solicitar endereços DNS através de servidores DHCP stateless.

Se a atribuição for dinâmica stateful, o host solicita através de um servidor DHCP stateful seu endereço ip, prefixo, roteador default e servidores DNS.

Exemplos de protocolos que trabalham em conjunto com o ipv6 são RIPng, OSPFv3, EIGRP for ipv6

Sintaxe de Configuração do ipv6 no IOS:

Router(config)#ipv6 address 2340:1111:AAAA:1::/64 eui 64

Sintaxe de configuração de protocolos de roteamento

Router(config)#ipv6 unicast-routing Habilita o roteamento ipv6

Router(config)#ipv6 router rip name Habilita o protocolo de roteamento selecionado

Router(config-if)# ipv6 rip name enable

Alguns recursos estão disponíveis para serem usados com ipv6, como o dual stacking, que nada mais é do que uma interface de rede ter dois endereços, um ipv6 e outro ipv4. Esse recurso é muito útil no processo de migração. O Tunelamento ipv6-to-ipv4 também esta disponível. Esse recurso funciona com uma rede que trabalha com ipv6 mas as redes no caminho ainda operem em ipv4, o roteador encapsula o pacote ipv6 dentro de um pacote ipv4 e no destino o processo é feito de modo ao contrario, com o roteador de destino desencapsulando o pacote ipv4 e encaminhando o pacote ipv6. Uma desvantagem nessa situação é o overhead necessário, reduzindo a capacidade da rede. Um tipo de tunelamento bastante usado é o Teredo, no qual um host com pilhas duais crie um túnel para outro host, com o próprio host criando o pacote ipv4 e encapsulando no pacote ipv6.

Protocolo PPP

Protocolo PPP (Point-to-Point Protocol)

É um protocolo de enlace de dados (camada 2) para transmissão de pacotes através de linhas seriais. O protocolo PPP suporta linhas síncronas e assíncronas. Normalmente ele tem sido utilizado para a transmissão de pacotes IP na Internet.


O Point-to-Point Protocol é projetado para transportar pacotes através de uma conexão entre dois pontos. A conexão entre os pontos deve prover operação full-duplex sendo assumido que os pacotes são entregues em ordem. Estas características são desejadas para que o PPP proporcione uma solução comum para a conexão de uma grande variedade de hosts, bridges e routers.

Encapsulamento

O encapsulamento do PPP provê multiplexação de diferentes protocolos da camada de rede simultaneamente através do mesmo link. Este encapsulamento foi cuidadosamente projetado para manter compatibilidade com os suportes de hardware mais comumente utilizados.

Somente 8 octetos adicionais são necessários para formar o encapsulamento do PPP se o compararmos ao encapsulamento padrão do frame HDLC. Em ocasiões em que a largura de banda é crítica o encapsulamento e o frame pode ser encurtado para 2 ou 4 octetos.

Para suportar implementações de alta velocidade, o encapsulamento padrão usa somente campos simples, desta forma o exame do campo para a demultiplexação se torna mais rápida.

LCP – Link Control Protocol

Para ser suficientemente versátil e portável para uma grande variedade de ambientes, o PPP provê um Link Control Protocol.

O Link Control Protocol é usado para automaticamente concordar sobre as opções de formato de encapsulamento, lidar com variações nos limites de tamanho dos pacotes, detectar loops infinitos, detectar erros de configuração, iniciar e terminar a conexão.  É usado para ativar e desativar linhas de transmissão, testá-las e negociar opções de funcionamento.

Opcionalmente o LCP pode prover facilidades de autenticação de identificação e determinação de quando o link está funcionando apropriadamente ou quando está falhando.

NCP – Network Control Protocol

O NCP é composto por uma família de protocolos de rede. Ele estabelece e configura os diferentes protocolos na camada de rede que serão utilizados pelo PPP.

Links ponto-a-ponto tendem a agravar alguns problemas comuns a diversas famílias de protocolos de rede.  Por exemplo, atribuição e gerenciamento de endereços IP é especialmente difícil sobre circuitos comutados com links ponto-a-ponto. Estes problemas são tratados pela família de Network Control Protocols (NCPs), onde é necessário um gerenciamento específico para cada problema.

Autenticação

Existem dois modos de autenticação do ppp: CHAP e PAP. CHAP é o modo mais seguro, executando toda a fase de autenticação em modo criptografado, enquanto PAP é menos seguro, enviado as intormações de autenticação em texto puro. Para configurar a autenticação do ppp seguem os passos:

Router(config)#username name password secret

Router(config)#interface serial 0/1/0

Router(config-if)#encapsulation ppp

Router(config-if)#ppp authentication [ chap | pap ]

name: hostname do host remoto

secret: senha usada em ambos os hosts

Para ativar o encapsulamento ppp nas interfaces, basta ativar o subcomando de interface nos hosts:

Router(config-if)#encapsulation ppp

Protocolo EIGRP

EIGRP= O protocolo EIGRP é um protocolo de roteamento classless, com isso suporta VLSM e sumarização, e é considerado híbrido por ter características de protocolos distance vector e link-state. Igual ao IGRP, ele usa o conceito de sistema autônomo para descrever um grupo de routers. Usa o conceito de upgrade incremental para preservar a largura de banda, enviando assim, somente as rotas alteradas, a não ser que um novo router entre na rede, neste caso é enviado a tabela completa. O EIGRP envia sua tabela pra os vizinhos no endereço de multicast 224.0.0.10, tendo um limite de 224 saltos.

Para formar adjacência com routers vizinhos, algumas condições precisam ser satisfeitas:

Enviar e receber pacotes Hello ou ACKs. (pacotes hello são como keep-alives) (5 segundos se > T1 [1.544mbps] 60 se <)

Estar no mesmo sistema autônomo (AS)

Possuírem os mesmos parâmetros (K values).

Mesma Sub-rede IP – *Apenas endereços Ips primários formam adjacências. Ips secundários não formam.

Feasible distance: é a distancia até uma rede, distancia presente na tabela de roteamento, essa distancia é a métrica do seu vizinho até a rede (reported distance, advertised distance), acrescida da métrica até o vizinho.

Reported Distance (Advertised Distance): Distância anunciada por um roteador vizinho até um destino. Esta métrica sempre será menor que a Feasible distance (pois se for maior está ocorrendo um loop de roteamento).

Sucessor route: Rota principal para um destino. É apresentada no comando show ip route e no show ip eigrp topology como sucessor route.

Feasible Sucessor: Possível rota alternativa para um destino. Apresentada na tabela de topologia e somente passa para a tabela de roteamento quando a sucessor route torna-se inalcançável ou tem um custo maior que a FS.

Feasible Condition: Quando um vizinho reporta uma AD menor que a FD.

O primeiro valor entre parêntese (3011840/2169856) indica a FD, enquanto segundo indica a RD para a rede remota.

Router1$ show ip eigrp topology

-output omitted-

P 192.168.10.0/24, 1 successors, FD is 3011840

via Summary (3011840/0), Null0

via 172.16.31.1 (41024000/2169856), Serial0/0/0

P 192.168.10.4/30, 1 successors, FD is 3523840

via 192.168.10.10 (3523840/2169856), Serial0/0/1

P 192.168.1.0/24, 1 successors, FD is 3014400

via 192.168.10.10 (3014400/28160), Serial0/0/1

via 172.16.3.1 (41026560/2172416), Serial0/0/0

Feasible Distance

Reported Distance

Métrica: O atraso é a soma de todos os atrasos no caminho, e a banda é a banda com valor menor. A formula é a seguinte métrica = banda + atraso, aonde a banda é calculada como (10000000/banda de menor valor no caminho)x256.

Menor BANDA = 56K
Atraso (soma) = 2000 + 400 (tens of microseconds)
Métrica = 10000000/56 +2400 x 256 = 46328685

O EIGRP mantém 3 tabelas:

Neighbor Table: Tabela de todo o vizinho, com seus respectivos IPs, interfaces de saída, valores de timers e tempo na tabela

Topology Table: Tabela com a topologia completa da rede, de todas as redes diretamente conectadas aos vizinhos.

Routing Table: Tabela de roteamento propriamente dita

O Protocolo DUAL provê um rápido tempo de convergência, mantendo uma rota backup, para se uma rota tornar-se inacessível, ela for colocada na tabela de roteamento.

EIGRP suporta redes descontíguas, mas nestes casos o comando auto-summarization tem que ser desativado, por este ser ativado por padrão.

As métricas padrão do protocolo EIGRP são K1 (bandwidth) e K3 (delay), mas também pode suportar K2 (load), K4 (reability) e K5 (MTU Size).

No comando show ip eigrp topology as rotas precedidas da letra P significam que a rota está em estado passivo (passive state) e a rota está normal. Quando a rota está inacessível ela se encontra  em A (active-state) e está a procura da rota

Router(config)#router eigrp (AS)

Router(config)#router eigrp 20

Router(config-router)network 192.168.20.0

Protocolo Frame Relay

Protocolo Frame Relay

Definido nas camadas Física (Camada 1) e de Enlace (Camada 2), o protocolo Frame Relay é usado para interconectar duas ou mais LANs. Para ser mais eficiente, ele usa a técnica de multiplexação, e usa o campo de CRC, do frame, para detectar erros na transmissão, porém, para maximizar a largura de banda, não os corrige, passando esta tarefa para as camadas superiores.

Usado em diversas interfaces, o Frame Relay provê uma comunicação entre dispositivos DTEs através de dispositivos DCEs. Por operar somente até a camada 2, qualquer informação de camada de rede (IP, IPX, AppleTalk), é totalmente irrelevante para ele. Para isso, é usado o artifício de PVC (Permanent Virtual Circuit), ou seja, um circuito virtual é criado, sendo assim, os dispositivos se enxergam como se estivessem conectados diretamente. Esses circuitos são conexões lógicas criadas por dispositivos DTEs através de uma rede packet-switched e identificadas por um DLCI (Data Link Connection Identifier) (a grosso modo, similar ao MAC Address nas redes Ethernet). Existe uma outra derivação de PVC, que é o SVC (Switched Virtual Connection) que são circuitos baseados em pacotes, não criando assim um circuito virtual permanente.

Operação de comunicação Frame Relay:

  1. O Host envia um frame com o endereço MAC de destino o router.
  2. O Router descarta o frame e analisa o endereço IP de destino, analisa na sua tabela de roteamento e envia o pacote pela interface apropriada. (se a rota não for encontrada e não tiver um gateway of last resort o pacote será descartado).
  3. O pacote será encapsulado em um frame Frame Relay, e será enviado para a rede Frame Relay, contendo o  número DLCI da interface serial (O DLCI identifica o PVC) para os routers e switches da operadora participante Frame Relay.
  4. O dispositivo CSU/DSU recebe o sinal digital, codifica na “linguagem” Frame Relay, e repassa para o PSE.
  5. O CSU/DSU é conectado ao demarc. Esse por sua vez, geralmente é uma tomada RJ-45.
  6. O Demarc é conectado ao loop local, que é conectado ao CO (Central Office). O loop local se conecta ao CO geralmente por par trançado ou fibra ótica.
  7. O CO recebe o frame e envia para a “nuvem” Frame Relay. O endereço IP destino e o numero DLCI são analisados.
  8. Alcançando o switching office mais próximo, o frame é enviado através do loop local. O frame é recebido pelo demarc e encaminhado para o CSU/DSU. O Router recebe o frame e o envia para a rede local.

Configurando Frame Relay em redes Cisco

Para configurar Frame Relay em routers Cisco, você deve especificar também o encapsulamento:

Router(config)#interface serial0/0 | encapsulation frame-relay [ietf – cisco]

Obs: Se nada for especificado após o encapsulation, será escolhido o modo de encapsulamento default cisco (que só é funcional com routers Cisco).

DLCI – Data Link Connection Identifiers

Para circuitos virtuais serem estabelecidos, DLCIs são designados aos dispositivos (começando a partir do número 16). Eles são usados para se distinguirem na rede Frame Relay, uma vez que a “nuvem” opera em camada 2, não identificando endereços IPs. Esse mapeamento IP X DLCI é feito manualmente, ou dinamicamente através do protocolo I-ARP (Inverse Address Resolution Protocol), com o comando inverse-arp.

O número DLCI de cada dispositivo pode ser igual, se eles não estabelecerem uma conexão ponto-a-ponto direta, como na figura:

Funcionamento dos DLCIs em uma rede Frame Relay

Configuração de um número DLCI para se associar a uma interface:

Router (config-if)# frame relay interface-dlci 16

Mapeamento IP X DCLI

Router(config)# int s0

Router(config-if)# encap frame

Router(config-if)#int s0.16 multipoint

Router(config-if)#no frame-relay inverse-arp

Router (config-if)#ip address 172.16.30.1 255.255.255.0

Router (config-if)#frame-relay map ip 172.16.30.17 17 broadcast

Router (config-if)#frame-relay map ip 172.16.30.18 18 broadcast

Router (config-if)#frame-relay map ip 172.16.30.19 19 broadcast

LMI – Local Management Interface

A interface de gerenciamento local (LMI) nada mais é do que uma série de recursos implementado pela Cisco, para prover uma comunicação de rede mais eficiente através da rede Frame Relay. O LMI é um padrão de sinalização entre um dispositivo CPE (como um router) e um frame switch, e é responsável pelo gerenciamento e manutenção do status entre esses dispositivos. Mensagens LMI provêm informações como: Keepalives, Multicasting, Endereçamento Multicasting e Status dos Circuitos Virtuais. (O LMI é similar ao protocolo CDP dos routers Cisco). Existem três tipos de sinalização LMI: Cisco, ANSI e Q993A. O Padrão é Cisco.

Routers recebem informações LMI em sua interface LMI e atualiza o status dos circuitos virtuais para um dos três diferentes estados:

Ativo – Tudo se encontra ativo e os routers podem trocar informações

Inativo – A Interface do router em questão se encontra ativa e conectada ao switching office, mas o router na outra ponta não.

Deleted – Nenhuma informação LMI transmitida pelo switch Frame Relay está sendo recebida pelo router. Inconsistência no mapeamento DLCI ou no próprio link pode estar ocorrendo.

Subinterfaces

Subinterfaces são criadas em interfaces Frame Relay para se tornar mais flexíveis.

Sintaxe: int s0 | encapsulation frame-relay | int s0.16 [multipoint – point-to-point]

Controle de Congestionamento empregado pelo Frame Relay


DE – Quando um router Frame Relay detecta congestionamento na rede, ele ativa o bit DE no cabeçalho do pacote frame relay, (de 0 para 1). Se o switch frame relay estiver congestionado, ele vai descartar todos os pacotes com o bit ativado (bit 1).

FECN (Forward Explicit Congestion Notification) – Quando a rede frame relay identifica um congestionamento na “nuvem”, o switch ativa o bit FECN no cabeçalho do pacote frame relay. Isso informará ao DCE destino que a rota recém atravessada pelo pacote em questão encontra-se congestionada.

BECN (Backward Explicit Congestion Notification) – Quando o switch detecta um congestionamento na rede, ele envia um pacote para o router de origem, para diminuir o fluxo de pacotes.

CIR – Commited Information Rate

O CIR, é um taxa de “garantia de banda” (em Kbps), que os provedores oferecem. Esse valor vai ser entregue ao cliente o tempo inteiro, entretanto, em algumas situações, a conexão pode alcançar taxas superiores. Algumas empresas oferem o CIR de 0 (zero), o que significa que os pacotes originados pelo router da operadora sempre serão enviado com o bit DE ativado. Isso não garante nenhuma banda, mas em troca, o custo é bem menor.

Taxa de Acesso

Taxa máxima que um DTE pode transmisitir para um DCE na rede Frame-Relay. Geralmente uma taxa múltipla de 64kbps

Alguns comandos úteis na monitoração de redes Frame Relay.

show frame-relay lmi: estatísticas do tráfego LMI entre routers e siwtch em uma rede FR

show frame-relay pvc: apresentra todas os circuitos virtuais ativos e seus DLCIs, e informações sobre os bits FECN e BECN.

show interface: informações gerais sobre estatísticas LMI, tráfego de camada 2 (enlaçe) e camada 3 (rede), encaspulamento usado, e tipo de LMI usado.

show frame-relay map: apresenta o mapeamento IP x DLCI.

debug lmi: apresenta na tela (console) toda a comunicação router-switch, auxiliando na solução de problemas.